Elevated Error Rates and Poor Performance
Incident Report for Modern Treasury
Resolved
Between 1:10 PM and 1:13 PM PST, the platform may have experienced slow performance.
Posted Sep 29, 2021 - 13:41 PDT
Investigating
The Modern Treasury application and API may be experiencing degraded performance. We are investigating.
Posted Sep 29, 2021 - 13:13 PDT
This incident affected: Platform/API.