Scheduled Maintenance.
Incident Report for Modern Treasury
Resolved
This incident has been resolved.
Posted Oct 16, 2021 - 23:07 PDT
Update
Maintenance.
Posted Oct 16, 2021 - 21:32 PDT
Investigating
The Modern Treasury application and API may be experiencing degraded performance. We are investigating.
Posted Oct 16, 2021 - 21:31 PDT
This incident affected: Platform/API.