An automated up-time check has failed.
Incident Report for Modern Treasury
Resolved
Between 2059 and 2101 PST, our web servers responded with elevated latencies due to an internal load test.
Posted Jan 14, 2022 - 21:39 PST
Investigating
The Modern Treasury application and API may be experiencing degraded performance. We are investigating.
Posted Jan 14, 2022 - 20:59 PST
This incident affected: Platform/API.