An automated up-time check has failed.
Incident Report for Modern Treasury
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 12:45 PST
Investigating
The Modern Treasury application and API may be experiencing degraded performance. We are investigating.
Posted Jan 13, 2022 - 12:42 PST