Modern Treasury - Modern Treasury API: Elevated error rate - Cell: us001 – Incident details

Modern Treasury API: Elevated error rate - Cell: us001

Resolved
Operational
Started 5 months agoLasted about 1 hour

Affected

Platform/API

Operational from 10:24 PM to 10:47 PM, Partial outage from 10:47 PM to 10:57 PM, Degraded performance from 10:57 PM to 11:51 PM

Ledgers API

Operational from 10:24 PM to 10:47 PM, Partial outage from 10:47 PM to 10:57 PM, Degraded performance from 10:57 PM to 11:51 PM

Compliance API

Operational from 10:24 PM to 10:47 PM, Partial outage from 10:47 PM to 10:57 PM, Degraded performance from 10:57 PM to 11:51 PM

Updates
  • Resolved
    Resolved

    The Modern Treasury API experienced elevated error rates from 5 PM EST until 5:15 EST, impacting customers in cell: us001. During this time, 3.32K API requests across all products failed.

    This issue has been resolved and all systems are currently operating as expected.

    You can find your cell number on the settings page of the Modern Treasury app.

  • Update
    Update

    We have identified and resolved the issue that caused this incident. While the Modern Treasury API is operational, there may be latency in creating transactions. We are actively monitoring the situation and will provide an update once all systems are fully restored.

  • Monitoring
    Monitoring

    We’ve rolled back the suspect change and quarantined the affected job. We are actively monitoring the issue. Thank you for your patience as we work to ensure full system stability.

    You can find your cell number on the settings page of the Modern Treasury app.

  • Investigating
    Investigating

    We are currently investigating elevated error rates in cell us001. During this time, some requests may return 500 errors, and customers may experience degraded performance when using the Modern Treasury API.

    You can find your cell number on the settings page of the Modern Treasury app.