Intermittent issue validating routing numbers during Payment Order creation

Resolved
Degraded performance
Started 11 months ago Lasted 38 minutes

Affected

Platform/API
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Some customers are experiencing valid routing numbers being marked as invalid. We are currently investigating this incident.