Duplicate incoming transactions and IPDs at Increase Bank

Resolved
Degraded performance
Started 8 months ago Lasted 1 day

Affected

Platform/API
Updates
  • Resolved
    Resolved

    This incident has been resolved and all duplicate transactions have been removed.

  • Monitoring
    Monitoring

    We have deployed a fix and identified all duplicate transactions and IPDs. We are now working with impacted customers to discard duplicates.

    All systems are fully operational.

  • Investigating
    Investigating

    We are currently seeing duplicate incoming transactions and Incoming Payment Details (IPDs) at Increase Bank. This does not impact outgoing transactions or create duplicate payments.

    We have identified the issue with the Increase API. We are working on deploying a fix shortly.

    This does not impact customers at other banks.