Scheduled Maintenance: Push to Warehouse

Completed
Scheduled for November 22, 2023 at 1:00 AM – 3:27 AM

Affects

Push to Warehouse
Updates
  • Completed
    November 22, 2023 at 3:27 AM
    Completed
    November 22, 2023 at 3:27 AM

    Maintenance is complete for all destination types except Databricks, where we're continuing to work on remediating an issue that is preventing incremental transfers of payment_orders, returns, and expected_payments.

    We are concluding our maintenance window at this time. We will follow up on resolution of the outstanding issue with Databricks customers.

  • In progress
    November 22, 2023 at 3:00 AM
    In progress
    November 22, 2023 at 3:00 AM

    Maintenance is now in progress

  • Planned
    November 22, 2023 at 1:00 AM
    Planned
    November 22, 2023 at 1:00 AM

    A Push to Warehouse maintenance window will take place per our regular schedule next week, on Tuesday 11/21, from 5 to 7 PM PST.

    Below is a summary of planned changes:

    • Add the following new table columns. With the exception of the "ledger_entries" change, these will be applied by re-syncing all historical table data. We expect this to take around 10 minutes in total, during which time tables may be unavailable.
      • Add "effective_at" column to the "ledger_entries" table.
      • Add "discarded_at" column to the "returns" table.
      • Add "ledger_transaction_id" column to "payment_orders", "expected_payments", and "returns".
    • Drop the "paper_items" table. Paper Items are deprecated and unused by Push to Warehouse customers.

    Please reach out to support@moderntreasury.com with any questions or concerns regarding the scope of these changes.