Modern Treasury - APP: Inability to Bulk Approve Payment Orders – Incident details

APP: Inability to Bulk Approve Payment Orders

Resolved
Operational
Started 11 days agoLasted about 1 hour

Affected

Platform/API

Degraded performance from 5:59 PM to 6:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Users may experience an error when attempting to approve payment orders via the Approvals page or when using the bulk approval feature in app.

    We are aware of this behavior and are actively working on a fix to resolve this issue.

    In the meantime, users can approve payment orders manually by navigating to individual payment orders:
    From there, select Review -> Approve, which will process the approval successfully.