Modern Treasury - Modern Treasury API: Elevated Latency – Incident details

Modern Treasury API: Elevated Latency

Monitoring
Operational
Started about 3 hours ago

Affected

Platform/API

Degraded performance from 11:12 PM to 1:39 AM, Operational from 1:39 AM to 12:00 AM

Ledgers API

Degraded performance from 11:12 PM to 1:39 AM, Operational from 1:39 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Modern Treasury has partnered with AWS Support as a problem has not been identified with our infrastructure. Additional logs have been enabled to assist in the identification of the cause.

  • Investigating
    Investigating
    We are investigating periods of elevated API latency. Customers may have experienced degraded performance while using the Modern Treasury API during the following time periods: 09/17/2025: 2:13 PM- 2:31 PM PT 09/16/2025: 6:46 PM-7:00 PM PT