Completed
Scheduled Maintenance: Push to Warehouse

Status
Resolved after about 2 hours
Started
December 20, 2023 at 1:00 AM
Completed
December 25, 2023 at 1:24 AM
Affects
Push to Warehouse
  • Completed
    December 20, 2023 at 3:00 AM
    Completed
    December 20, 2023 at 3:00 AM

    Maintenance has completed successfully. We opted not to make the planned change to the transaction_line_items table this time, as we observed behavior inconsistent with our staging environment. We plan to revisit this change in January.

  • In progress
    December 20, 2023 at 1:00 AM
    In progress
    December 20, 2023 at 1:00 AM

    Maintenance is now in progress

  • Planned
    December 20, 2023 at 1:00 AM
    Planned
    December 20, 2023 at 1:00 AM

    A Push to Warehouse maintenance window will take place per our regular schedule next week, on Tuesday 12/19, from 5 to 7 PM PST.

    Below is a summary of planned changes:

    • Add the following new table columns. These changes require re-syncing historical data for the affected tables. We expect this to take around 10 minutes in total, during which time data may be unavailable.
      • Add "payment_order_id" column to the "reversals" table.
      • Add "ledger_transaction_id" column to "incoming_payment_details" table.
    • Re-sync historical data for the "transaction_line_items" table. This is a one-time measure that will allow us to improve the speed and efficiency of transfers moving forward.
    • Introduce a new "ledger_account_settlements" table. As we recently announced via direct email, Modern Treasury is deprecating "ledger_account_payouts" effective 12/15/23, and we have advised customers to begin using "ledger_account_settlements" instead. The underlying data is the same. Modern Treasury will continue to sync "ledger_account_payouts" to customer warehouses through at least March 15, 2024.

    Please reach out to support@moderntreasury.com with any questions or concerns regarding the scope of these changes.