Modern Treasury - Increased API Failures – Incident details

Increased API Failures

Resolved
Degraded performance
Started 4 months agoLasted 30 minutes

Affected

Platform/API

Degraded performance from 1:23 AM to 1:54 AM

Ledgers API

Degraded performance from 1:23 AM to 1:54 AM

Compliance API

Degraded performance from 1:23 AM to 1:54 AM

Updates
  • Resolved
    Resolved

    Between 18:11 and 18:37 we saw an increase in API error rates in us000. This mostly impacted operations related to ledgers listing. We have completed reverting the suspected database operation.

  • Monitoring
    Monitoring

    We've identified a potential fix involving the rollback of a database optimization. Error levels are steadily decreasing and monitoring is ongoing.

  • Identified
    Identified

    Only affecting customers in cell us000

  • Investigating
    Investigating
    We are currently investigating this incident.