Modern Treasury - Intermittent Connection Errors:API – Incident details

Intermittent Connection Errors:API

Resolved
Degraded performance
Started 4 months agoLasted about 17 hours

Affected

Platform/API

Degraded performance from 3:24 AM to 8:05 PM

Updates
  • Resolved
    Resolved

    Modern Treasury has identified a network connectivity issue between two AWS regions is likely the cause of the errors a subset of customers experienced May 23rd. We’ve updated our systems to improve performance and reliability for our API services. We are seeing consistent and successful activity at this time.

  • Monitoring
    Monitoring

    Currently monitoring as functionality appears stable.

  • Investigating
    Investigating

    Modern Treasury is currently investigating reports of intermittent connection errors for a subset of API calls affecting US001