Partial API Outage

Resolved
Degraded performance
Started 10 months ago Lasted about 1 hour

Affected

Platform/API
Ledgers API
Compliance API
Updates
  • Resolved
    Resolved

    The Modern Treasury API has recovered and all operations are normal.

    This incident was due to a spike of high database load causing us to return errors to ~4% of list and retrieve requests from 7:26 PDT to 7:28 PDT. The increase in database load came from an internal job that has now been fixed.

  • Monitoring
    Monitoring

    We saw a low level of intermittent failures on list and retrieve endpoints. We are currently investigating but believe the situation is resolved.

  • Investigating
    Investigating

    The Modern Treasury application and API may be experiencing degraded performance. We are investigating.