Partial API/UI Outage (Create Payment Order)

Resolved
Partial outage
Started 5 months ago Lasted about 1 hour

Affected

Platform/API
Updates
  • Resolved
    Resolved

    This incident has been resolved, and only one Payment Order was affected.

    At 9:35 AM PST, API requests to the Payment Order Create endpoint for wire transfers to one of our banking partners would return a 500. This was due to a bug in a recent change to our routing number lookup service. We noticed the elevated 500 rate due to the retrying Payment Order at 9:40 AM PST and began our investigation. By 10:35 AM PST we deployed a fix for this bug and confirmed that the affected Payment Order was successfully created.

  • Monitoring
    Monitoring

    We have deployed a fix and are currently monitoring the result.

  • Identified
    Identified

    Creating Payment Orders via the UI or API is currently failing for less than 1% of requests for a small subset of customers and may result in a 500. We have identified the cause of the issue and are currently working on a fix.