Platform/API

Operational

Ledgers API

Operational

Compliance API

Operational

Push to Warehouse

Operational

Marketing Website

Operational

Notice history

Apr 2024

Scheduled Maintenance: Push to Warehouse
Scheduled for April 17, 2024 at 12:00 AM – 2:00 AM about 2 hours
  • Planned
    April 17, 2024 at 12:00 AM
    Planned
    April 17, 2024 at 12:00 AM

    A Push to Warehouse maintenance window will take place per our regular schedule next week, on Tuesday 4/16, from 5 to 7 PM PST.

    During this time, we plan to make the following change:

    1. Introduce the type and receiving_account_id fields to the payment_orders table, which existing recipients of Modern Treasury Payments tables will receive. The payment_orders table will be re-synced to ensure these fields are populated on historical records.

    Please reach out to support@moderntreasury.com with any questions or concerns regarding the scope of this changes.

Mar 2024

Scheduled Maintenance: Push to Warehouse
  • Update
    March 20, 2024 at 7:52 PM
    Completed
    March 20, 2024 at 7:52 PM

    Shortly after the completion of this maintenance window we experienced an incident that impacted our ETL process. This incident has since been resolved.

    As part of the incident remediation process, transfers for the balance_reports table have been paused since ~11:30 PM PT and data may be stale. We are actively working to re-enable transfers for balance_reports and will update this maintenance update when we have a timeline estimate.

    No other tables are affected, including the newly added payment_references table.

  • Completed
    March 20, 2024 at 2:00 AM
    Completed
    March 20, 2024 at 2:00 AM
    Maintenance has completed successfully
  • In progress
    March 20, 2024 at 12:00 AM
    In progress
    March 20, 2024 at 12:00 AM
    Maintenance is now in progress
  • Planned
    March 20, 2024 at 12:00 AM
    Planned
    March 20, 2024 at 12:00 AM

    A Push to Warehouse maintenance window will take place per our regular schedule next week, on Tuesday 3/19, from 5 to 7 PM PST.

    During this time, we plan to make the following changes:

    1. Introduce new balance_reports and payment_references tables, which existing recipients of Modern Treasury Payments tables will receive.

    2. Re-sync historical data for the transaction_line_items table. This is a one-time measure that will allow us to improve the speed and efficiency of transfers moving forward.

    Please reach out to support@moderntreasury.com with any questions or concerns regarding the scope of this changes.

Feb 2024

Feb 2024 to Apr 2024