Resolved
An automated up-time check has failed.

Started
March 30, 2022 at 7:13 PM
Status
Resolved after 1 minute
Affected
Platform/API

Impact

Major outage
  • Resolved
    March 30, 2022 at 7:14 PM

    The Modern Treasury application and API have recovered.

  • Investigating
    March 30, 2022 at 7:13 PM

    The Modern Treasury application and API may be experiencing degraded performance. We are investigating.