Resolved
An automated up-time check has failed.

Started
May 19, 2022 at 9:09 PM
Status
Resolved after 9 minutes
Affected
Platform/API

Impact

Major outage
  • Resolved
    May 19, 2022 at 9:18 PM

    The Modern Treasury application and API have recovered.

  • Investigating
    May 19, 2022 at 9:09 PM

    The Modern Treasury application and API may be experiencing degraded performance. We are investigating.