Modern Treasury - Elevated Reconciliation Delays – Incident details
All systems operational
Elevated Reconciliation Delays
Resolved
Degraded performance
Started about 1 year agoApril 30, 2025Lasted about 3 hours6:569:40 PMUTC
Affected
Platform/API
Degraded performance from 6:56 PM to 9:40 PM
Updates
Resolved
UTC
Resolved
UTC
This is now resolved.
Monitoring
UTC
Monitoring
UTC
A fix has been deployed.
Identified
UTC
Identified
UTC
Our engineers have identified the cause of the problem and are working on a fix. Affected Transactions have been manually reconciled.
Investigating
UTC
Investigating
UTC
Customers who are utilizing both the Ledgers and Payments product together are experiencing reconciliation delays or incomplete reconciliation. Engineering is actively investigating at this time.