Modern Treasury - APP: Inability to Approve Payment Orders – Incident details

APP: Inability to Approve Payment Orders

Resolved
Degraded performance
Started 15 days agoLasted 27 minutes

Affected

Platform/API

Degraded performance from 9:26 PM to 9:53 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We're actively investigating issues related to Payment Order approvals.