Modern Treasury - App and Connectivity Issue – Incident details

App and Connectivity Issue

Resolved
Partial outage
Started 3 days agoLasted 20 minutes

Affected

Platform/API

Major outage from 6:52 PM to 7:12 PM

Updates
  • Postmortem
    Postmortem

    Impact

    • Login was unavailable for customers.

    • API traffic was unavailable for us000 and us002 for approximately 36 minutes, from 10:34 AM to 11:10 AM.

    • All other cells were unaffected.

    Affected cells

    • us000, us002


    What Happened
    As part of ongoing infrastructure work to improve long-term stability and reduce operational overhead, we previously decommissioned an unused internal service and later removed related configuration.
    On January 7, an AWS-initiated maintenance event caused a restart of a database connection service used by our platform. During the restart, a missing configuration dependency prevented the service from starting correctly. As traffic increased, the remaining healthy capacity was exhausted, leading to a temporary outage affecting logins and API traffic.

    Resolution
    The issue was identified and resolved, and service was fully restored. We have implemented additional safeguards and monitoring to prevent similar incidents in the future.

  • Resolved
    Resolved

    This is now resolved.

  • Investigating
    Investigating

    Users are currently unable to access the Modern Treasury application. Our engineering team is investigating.