Partial API outage

Resolved
Operational
Started 9 months ago Lasted 12 minutes

Affected

Platform/API
Ledgers API
Compliance API
Marketing Website
Updates
  • Resolved
    Resolved

    The Modern Treasury API has recovered and all operations are normal.

    This incident was due to a spike of high database load causing us to return errors to ~2% of list and retrieve requests from 2:45 PM PDT to 2:50 PM PDT.

  • Monitoring
    Monitoring

    We saw a low level of intermittent failures on list and retrieve endpoints between 2:45 PST to 2:50 PST. We are currently investigating but believe the situation is resolved.